Tuesday, March 1, 2011

How to Make a Workspace Compatible with Older Versions of CVI

If you are working with a new version of CVI, you might have problems opening your projects with older CVI versions.

Assuming you did not use any new feature that doesn't exist in older CVI versions, the only thing you have to do in order to open and work with your project (and in order to build a distribution kit) with an older CVI is to save the UIR file (or files) in the correct format:

1) When opening the project or workspace you might get an error window telling you that the project was written in a newer version of CVI... dismiss it (Continue) and carry on.

2) Open the .uir file (you might get another error message, dismiss it).
3) While in  the .uir window, click 'File' and then save the .uir file with the same name as before (shown in the image below):

Pay attention to the lower line in the file select window, it allows you to select the .uir version:

After saving the .uir file in the correct version you will be able to work freely within the workspace.

No comments:

Post a Comment